Flash CityScape Project
Project Overview
[bookmark: iddle1088][bookmark: iddle1348][bookmark: In_this]Project files:  http://www.asciutto.com/flash/cityscape
General Notes
· Save your work periodically throughout the project
· Drawing object mode is off unless otherwise stated
· All colors are suggested, feel free to use your creativity
Part 1 - Create Library Items
· Use the Stage as a temporary drawing canvas to create Graphic and Button Symbols
Part 2 - Import Library Items
· Import other graphics into the Library
Part 3 – Assemble the Scene
· Create multiple layers from the library items
Part 4 – Add Animation
· Create a motion tween
Part 5 – Control the Timeline
· Define the Button symbol
· Add ActionScript
Part 6 – Add Sound
· Import sound into the library
· Include sound in the main timeline
Part 7 – Add Text
· Include a Movie title
Part 8 – Extra Enhancements
· Enhance with a Movie Clip symbol
Part 1 - Create Library Items
[bookmark: The_first]Create a new project folder
· Name it: CityScape Flash Project
Define Movie Properties
1. Create a new Flash movie – ActionScript 2.0
2. Choose Modify > Document from the menu
· Width:	600px 
· Height:	400px
· Background color: white
· Frame rate:	12
· Ruler units:	pixels
· Click OK
3. Save the Flash source file into your folder, name it: CityScape.fla
[bookmark: Grid][bookmark: _Toc140400187]The Grid
1. Choose View > Grid > Edit Grid from the menu
· Click the Color box and select gray to have the grid lines display in gray.
· Select Show Grid and Snap to Grid
· Set the Horizontal  and Vertical grid spacing to 20px
· Confirm the Snap accuracy is Normal
· Click OK
[bookmark: Inspector][bookmark: Oval][bookmark: _Toc140400189][image: ]
The Oval Tool
Draw an ellipse
1. Tool: 	Oval
2. Stroke:	Color - Black, Size - 3px, Style - Solid
3. Fill: 	Color #0066CC (can substitute any color)
4. Size: 	120x60
Note: 	Use the Grid & Snapping by starting to draw the oval at a grid intersection
and dragging over 6 and down 3 squares
[image: ]
[bookmark: Symbol][bookmark: _Toc140400190]Convert to a Button Symbol
Add the Oval to the Library
1. Tool: Selection
2. Select the entire oval (stroke and fill)
3. Choose Modify > Convert to Symbol from the menu
· Name: 	Play
· Type: 	Button
4. Delete the Button symbol from the Stage
[bookmark: Gradients][bookmark: _Toc140400191]Gradients
Start with a Rectangle
1. Tool: 	Rectangle
2. Stroke: 	no stroke
3. Fill: 	Color #0066CC (doesn’t matter, we will be changing it)
4. Size: 	600x240 (cover the top 60% of the stage)
5. Delete the Button symbol from the Stage
Convert the fill color to a Linear Gradient
1. Tool: Selection
2. Select the rectangle
3. Open to Color panel
· Select fill color, linear gradient
· Note: The rectangle changes to a default black-white gradient
· Set the left gradient color picker to: #33CCFF (can substitute any color)
· Set the right gradient color picker to: #FFCC66 (can substitute any color)
[image: ]
Transform the Gradient
1. Tool: Gradient Transform
2. Select the rectangle
3. Rotate the gradient 90° CW
4. Adjust the size of the gradient to fill the rectangle
[image: ]
Convert to a Graphic Symbol
Add the Rectangle to the Library
1. Tool: Selection
2. Select the rectangle
3. Choose Modify > Convert to Symbol from the menu
· Name: Sky
· Type: Graphic
4. Delete the Sky symbol from the Stage
[bookmark: Pencil][bookmark: _Toc140400193]The Pencil Tool - Draw a Tree
Create the Tree Trunk
1. Tool: 	Pencil
2. Stroke: 	Color #663300(or any color you’d like),  Size - 1px, Style - Solid
3. Fill: 	There is no fill, the Pencil is a stroke tool
4. Pencil Mode: Smooth, Smoothing 50%
5. Draw a tree trunk
[image: ]
Fill the Tree Trunk
1. Tool: 	Paint Bucket
2. FIll: 	Color #663300 (or any color you’d like)
3. Gap Size:	Close large gaps
4. Fill the tree trunk 	
[image: ]

Convert the Tree Trunk to an Object
1. Tool: 	Selection
2. Select the entire tree trunk
3. Choose Modify > Combine Objects > Union
Create the Tree Top Object in a similar way as the Tree Trunk
1. Color: 	#336600
Overlay both objects and create a Graphic Symbol
1. Use the transform tool if needed to re-size
2. Select both the tree trunk and top
3. [image: ]Convert to a Graphic Symbol called: Tree
4. Delete the Tree symbol from the Stage
                  [image: ]
The Oval Tool - Draw a Tire
Draw a Tire
1. Tool: 	Oval
2. Stroke:	no stroke
3. Fill: 	Color - #000000 (Back)
4. Size: 	60x60
Draw a Hub Cab
1. [image: ]Tool: 	Oval
2. Stroke:	no stroke
3. Fill: 	Color - #CCCCCC, Size - 1px, Style - Solid 
4. Size: 	20x20
5. Overlay the Hub Cap into the center of the Tire
Convert to a Graphic Symbol
1. Select the Tire and Hub Cab
2. Convert to a Graphic Symbol called: Tire
3. Delete the Tire symbol from the Stage
The Oval Tool - Draw Windows and Doors
Draw a Door
1. Note: You may temporarily change the stage background color to better see the white object Convert
2. Tool: 	Rectangle
3. [image: ]Stroke:	Color - Black, Size - 1px, Style - Solid
4. Fill: 	Color - #000000 (White, or any color you’d like)
5. Size: 	20x40
6. Convert to a Graphic Symbol called: Door
7. Delete the Door symbol from the Stage
Draw a Window
1. Note: You may temporarily change the stage background color to better see the white object Convert
2. Tool: 	Rectangle
3. [image: ]Stroke:	Color - Black, Size - 1px, Style - Solid
4. Fill: 	Color - #000000 (White, or any color you’d like)
5. Size: 	20x20
6. Convert to a Graphic Symbol called: Window
7. Delete the Window symbol from the Stage
The Line Tool - Draw a Car
Outline a Car Chassis
1. Tool: 	Line
2. Stroke:	Color - Black, Size - 3px, Style - Solid
3. Fill: 	No fill, the Line is a stroke tool
4. Size: 	Using the Grid intersecting points, outline a car 
[image: ]
Curve the Outline
1. Tool: 	Selection
[image: ]

Fill with Color and Remove the Stroke
1. Tool: 	Paint Bucket
2. Fill: 	Color Body - #FF0000 (Red, or any color you’d like)
3. Fill: 	Color Lights - #FFFFFF (White, or any color you’d like)
4. Tool: 	Selection
5. Double-click on the stroke
6. Press the Delete key
[image: ]
Add the Tires, Windshield and Wheel
1. Tool: 	Line
2. Stroke:	Color - Black, Size - 2px, Style – Solid
3. Draw the Windshield and Wheel
4. Add the Tire symbol from the Library
Convert to a Graphic Symbol
1. Select the Car
2. Convert to a Graphic Symbol called: Car
3. Delete the Car symbol from the Stage
[image: ]
The Line Tool - Draw the Buildings
Outline the Buildings
1. Tool: 	Line
2. Stroke:	Color - Black, Size - 3px, Style - Solid
3. Size: 	Using the Grid intersecting points, outline buildings across the stage width
[image: ] 

Curve a few Roof Tops, fill each building with color, Remove the Stroke
1. Tool: 	Selection, Paint Bucket
2. Fill:	Any color
[image: ]
Transform the Windows and Doors
1. Tool: 	Selection
2. Double-click the Door Graphic Symbol in the Library to enter the Library item
3. Open the Transform Panel
4. Transformt the Vertical and Horizontal scale to 60% of the original size
5. Double-click the Window Graphic Symbol in the Library to enter the Library item
6. Open the Transform Panel
7. Transformt the Vertical and Horizontal scale to 60% of the original size
8. Go back to Scene 1
Add the Windows and Doors
1. Tool: 	Selection
2. Add the Windows and Doors from the Library to the buildings
Convert to a Movie Clip Symbol
1. Select all the buildings, doors and windows
2. Convert to a Movie Clip Symbol called: Buildings
3. Delete the Buildings symbol from the Stage
[image: ]


Library at this point
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Part 2 - Import Library Items
Import the Tree Clip Art Image to the Stage
1. Choose File > Import > Import to Stage
2. Select “Tree_ClipArt.gif”
Convert the Tree Clip Art Image to a vector graphic
1. Select the tree
2. Choose Modify > Bitmap > Trace Bitmap
3. Accept the defaults
· Color threshold: 100
· Minimum area: 8
Delete the white background and save it as a Graphic Symbol
1. De-select the tree
2. Select the white background area
3. Press the “delete” key
4. Select the remaining tree
5. Convert to a Graphic Symbol called: Tree2
6. Delete the Tree2 symbol from the Stage
Note: Once the tree is converted to a Graphic symbol the original imported .gif may be deleted
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Import the Tree Clip Art Image to the Stage
1. Choose File > Import > Import to Stage
2. Select “Tree_Illustrator.ai”
3. In the import dialog box, double-click select the top layer “svg2447” and rename it Tree3
4. Check the box to import as movie clip
5. Choose Convert layers to: Flash layers
6. Delete the Tree3 Movie Clip symbol from the stage
Note: The Tree3 Movie Clip symbol will be placed in the Library within the Tree_Illustrator.ai folder
[image: ]
Library at this point
[image: ]
[bookmark: Layers][bookmark: _Toc140400195]Part 3 - Assemble the Scene
Define Layers
1. Rename the one layer to “Sky”
2. Drag the Sky Symbol from the Library and align it to the stage left and top
3. Insert a new layer above “Sky” and name it “Buildings”
4. Drag the Buildings Symbol from the Library and position to line up with the bottom of the Sky
5. Move the Registration point of the Sky symbol to the top middle
6. Tool: 	Transform
7. With the Transform tool, drag the bottom middle Sky handle to adjust the effect of the gradient behind the buildings
8. Lock the Sky layer
9. Select the Buildings symbol
10. In the properties panel, add a drop shadow and bevel filter to give the buildings a 3D effect
11. Lock the Buildings layer
Add the Ground Layer
1. Insert a new layer above “Buildings” and name it “Ground”
2. Create 3 rectangle shapes below the Buildings of three different colors
3. Use black for the middle rectangle, it will be the road
4. Tool: 	Line
5. Properties: 	Color #FFFFFF,  Size - 3px, Style - Dashed
6. Select the Line tool and create a horizontal line in the middle of the road
7. Lock the “Ground” layer
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Turn off the Grid
1. Since the Grid is no longer visible, turn it off the avoid snapping to the Grid points
2. Choose View > Grid > Uncheck Show Grid
3. Choose View > Snappng > Uncheck Snap to Grid
Add the Tree Layer
1. Insert a new layer above “Ground” and name it “Trees”
2. Add the 3 Tree Symbols to the scene
3. Position and scale them as desired
4. Lock the Tree layer
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Layers at this point
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Part 4 - Add Animation
Add the Car Layer
1. Insert a new layer above “Ground” and name it “Car”
2. Increase the timeline to 100 frames in all layers
3. Add the Car symbol
4. Transform it to scale and position it off the Stage to the right aligned with the road
[image: ]
Create the Car Motion Tween
1. Add a Motion Tween for the Car symbol
· Right-click in frame 1 of the Car layer and select “Motion Tween”
2. Position the Playhead to frame 100
3. Move the Car symbol to the opposite side of the Stage horizontal to the road
4. Lock the Car layer
Note:  A Keyframe will be added to frame 100 of the Car layer and the motion path will be visible
[image: ]
Part 5 - Control the Timeline
Stop the Timeline
1. Insert a new layer above “Car” and name it “Action”
2. Open the ActionScript panel
3. Lock the Action Layer
4. Select the Stop command within the ActionScript 2.0 menu
· Global Functions > Timeline Control > stop
Note: This will stop the Timeline, test it with Ctrl+Enter
[image: ]
Edit the Button Symbol
1. Double-click on the Play Button symbol to enter it’s Timeline
2. Rename Layer 1 “Shape” in the Button Timeline
3. Insert 3 Keyframes in Over, Down and Hit
4. Change the Fill color of the button in the Over and Down frames
5. Lock the Shapes layer
6. Insert a new layer above and call it “Text”
7. Type the word “Play” (any font and color) within the Button shape
8. Optional: Text Layer
· Add 2 Keyframes in the Down and Hit
· Change the color of the word “Play” in these frames

[image: ][image: ]








Add the Button to the Scene
1. Select Scene1
2. Insert a new layer above “Car” and name it “Button”
3. Add the button to the bottom of the Stage
4. Select the Button symbol 
5. Open the Behaviors panel
6. Select a new Behavior from the + button
7. Movieclip > Goto and Play at frame or label
8. Accept the defaults and click OK
9. Lock the Button layer
10. Test you movie
[image: ]

Generated ActionScript from the Behavior Panel
[bookmark: _GoBack][image: ]


Part 6 - Add Sound
Import Sound to the Library
1. Import to Library the three sound files
· beepbeep.wav
· horn.wav
· horngoby.wav
Add the Sound Layer
1. Insert a new layer above “Button” and name it “Sound”
2. Within the Sound layer select frame 20 (or any frame) and inset a blank keyframe
3. Drag a sound clip anywhere to the Stage with the blank keyframe selected
4. Lock the Sound layer
Note:  Nothing appears on the stage but the sound wave will be added to the timeline
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Part 7 - Add Text
Import Sound to the Library
1. Insert a new layer above “Sound” and name it “Title”
2. Tool:	Text
3. Any color
4. Type CityScape (or anything else) at the bottom of the Stage
5. Lock the Layer

[bookmark: Sound][bookmark: _Toc140400203][image: ]

Part 8 - Extra Enhancements
Suggestions for Optional Additions
1. Add a Movie Clip symbol that contains an animated sequence above the Buildings
2. Create a new button symbol to control sound
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